ELRepo Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000792 [channel: elrepo/el7] kmod-nct6775 major always 2017-10-04 23:28 2017-10-11 13:34
Reporter JensKuehnel View Status public  
Assigned To pperry
Priority normal Resolution fixed  
Status resolved  
Summary 0000792: nct6775 is not running with Centos 7.4
Description When installing kmod-nct6775-0.0-3.20151222git.el7.elrepo.x86_64 on latest centos kernel-3.10.0-693.2.2.el7.x86_64. It is not working.

I installed it on a Hetzner EX41 with a Fujitsu D3401-H2x.

A rebuild of the package with kernel 3.10.0-693.2.2.el7.x86_64 instead of 3.10.0-327.el7 is fixing this problem.

An working rebuild is available at https://www.kuehnel.org/nct6775/ [^]
Additional Information The error message from weak-updates:

# echo /lib/modules/3.10.0-327.el7.x86_64/extra/nct6775/nct6775.ko | /sbin/weak-modules --add-modules --no-initramfs --verbose
weak module for nct6775.ko already exists for kernel 3.10.0-514.el7.x86_64, update case?
mkdir -p /lib/modules/3.10.0-514.el7.x86_64/weak-updates/nct6775
ln -sf /lib/modules/3.10.0-327.el7.x86_64/extra/nct6775/nct6775.ko /lib/modules/3.10.0-514.el7.x86_64/weak-updates/nct6775/nct6775.ko
Module nct6775.ko from kernel 3.10.0-327.el7.x86_64 is compatible with kernel 3.10.0-514.el7.x86_64
mkdir -p /lib/modules/3.10.0-693.2.2.el7.x86_64/weak-updates/nct6775
ln -sf /lib/modules/3.10.0-327.el7.x86_64/extra/nct6775/nct6775.ko /lib/modules/3.10.0-693.2.2.el7.x86_64/weak-updates/nct6775/nct6775.ko
rm -f /lib/modules/3.10.0-693.2.2.el7.x86_64/weak-updates/nct6775/nct6775.ko
rmdir --parents --ignore-fail-on-non-empty nct6775
Module nct6775.ko from kernel 3.10.0-327.el7.x86_64 is not compatible with kernel 3.10.0-693.2.2.el7.x86_64 in symbols: platform_driver_register
Falling back weak-modules state for kernel 3.10.0-693.2.2.el7.x86_64
rm -rf *
Skipping depmod for non-installed kernel 3.10.0-327.el7.x86_64
/sbin/depmod -ae -F /boot/System.map-3.10.0-514.el7.x86_64 3.10.0-514.el7.x86_64
Tags No tags attached.
Reported upstream
Attached Files

- Relationships

-  Notes
(0005546)
pperry (administrator)
2017-10-05 00:28

Thank you for the report.

I will update the package and get it rebuild for el7.4

Out of interest, does the distro nct6775.ko kernel driver support your hardware?
(0005547)
JensKuehnel (reporter)
2017-10-05 01:19

No, it tells me "no Device". That was the reason to try elrepo.
Thanks for all your help.
(0005559)
pperry (administrator)
2017-10-10 14:07
edited on: 2017-10-10 14:08

Apologies for the slow response.

I have updated the package to the latest upstream git snapshot and rebuilt it against the RHEL 7.4 kernel. The package has just been released to the testing repository and should be available on the mirrors shortly:

http://elrepo.org/linux/testing/el7/x86_64/RPMS/ [^]

kmod-nct6775-0.0-3.20171010git.el7_4.elrepo.x86_64.rpm

Please update / install and reboot to a 7.4 series kernel to test. If the package works as expected, I'll promote to the main repo.

Awaiting your feedback - thanks

(0005560)
JensKuehnel (reporter)
2017-10-11 11:29

This package works great! Thanks a lot.
(0005561)
pperry (administrator)
2017-10-11 13:34

Fantastic. Thanks for the feedback, I've moved it to the main repo.

Closing as fixed. Please feel free to reopen or file further bugs as required.

- Issue History
Date Modified Username Field Change
2017-10-04 23:28 JensKuehnel New Issue
2017-10-04 23:28 JensKuehnel Status new => assigned
2017-10-04 23:28 JensKuehnel Assigned To => pperry
2017-10-05 00:28 pperry Note Added: 0005546
2017-10-05 01:19 JensKuehnel Note Added: 0005547
2017-10-10 14:07 pperry Note Added: 0005559
2017-10-10 14:08 pperry Note Edited: 0005559
2017-10-10 14:09 pperry Status assigned => feedback
2017-10-11 11:29 JensKuehnel Note Added: 0005560
2017-10-11 13:34 pperry Note Added: 0005561
2017-10-11 13:34 pperry Status feedback => resolved
2017-10-11 13:34 pperry Resolution open => fixed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker