ELRepo Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000672 [channel: kernel/el7] kernel-ml minor have not tried 2016-09-17 03:07 2016-09-26 16:22
Reporter brad4 View Status public  
Assigned To toracat
Priority normal Resolution not a bug  
Status resolved  
Summary 0000672: kernel.sched_autogroup default differs from vendor kernel
Description sysctl kernel.sched_autogroup_enabled defaults to 1 in elrepo kernel(at least 7-ml and 7-lt), while 0 in vendors kernel.
It is not noticeable on desktop machines, but on 32-core machine it is quite visible that multiple threads get stuffed on 22 CPU cores.

Additional Information Fix should be one-line patch against kernel/sched_autogroup.c to set sysctl default, or as I work around now just add it to sysctl.conf/
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004861)
toracat (administrator)
2016-09-17 07:12

If this was something that could be set withing kernel config files, we would have been able to make necessary changes. However this requires a change in the kernel code. As we are supposed to build the source code "as is", we will not be able to do the suggested modification.
(0004863)
toracat (administrator)
2016-09-17 10:10

What we could do is to add a note to our wiki pages that alerts users that may be affected by the difference in this default option.
(0004865)
brad4 (reporter)
2016-09-17 17:15

Such resolution is perfect for me. Probably tell to make /etc/sysctl.d/*.conf with a healthy warning to not fix what is not broken ;)

also flipped to zero
kernel.nmi_watchdog (default is zero as per kernel doc, vendors disagree)
It is expected to log unhandled NMI-s post factum. Usually there is some other driver handling NMIs that are not genuine HW faults.

(and some obsoleted just went away over time)
kernel.auto_msgmni
net.ipv4.ipfrag_secret_interval
net.ipv6.ip6frag_secret_interval
net.core.warnings
(0004867)
toracat (administrator)
2016-09-26 16:22
edited on: 2016-09-26 16:22

The Known Issues section of the kernel-ml wiki page ( http://elrepo.org/tiki/kernel-ml [^] ) has been updated with a reference to this bug report.

I'm closing this but please feel free to reopen if you have further comments to make.


- Issue History
Date Modified Username Field Change
2016-09-17 03:07 brad4 New Issue
2016-09-17 03:07 brad4 Status new => assigned
2016-09-17 03:07 brad4 Assigned To => burakkucat
2016-09-17 07:12 toracat Note Added: 0004861
2016-09-17 10:10 toracat Note Added: 0004863
2016-09-17 17:15 brad4 Note Added: 0004865
2016-09-26 08:54 burakkucat Assigned To burakkucat => toracat
2016-09-26 16:22 toracat Note Added: 0004867
2016-09-26 16:22 toracat Status assigned => resolved
2016-09-26 16:22 toracat Resolution open => not a bug
2016-09-26 16:22 toracat Note Edited: 0004867


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker