kmod-fglrx

kmod-fglrx provides the AMD/ATI driver kernel module (fglrx.ko). It is built to depend upon the specific ABI provided by a range of releases of the same variant of the Linux kernel and not on any one specific build.

fglrx-x11-drv provides the proprietary AMD/ATI binary OpenGL X11 display driver files.

fglrx-x11-drv-32bit provides 32-bit compatibility libs for x86_64 systems.

After installing / updating this package, users are advised to reboot their system. Simply restarting X may not suffice, one needs to drop out of X, remove and reload the fglrx kernel module and restart X. For most end users, a reboot will be simpler ;)

Notes for users who previously installed with ATI's binary installer
Users who have previously installed the driver by running the binary installer provided by AMD/ATI are advised to uninstall it before attempting to install kmod-fglrx. For example, by running:

sh /usr/share/ati/fglrx-uninstall.sh


Notes for x86_64 users
If your system is running 64-bit and you require 32-bit libraries as well, you would need fglrx-x11-drv-32bit:

yum --enablerepo=elrepo install fglrx-x11-drv-32bit



Known Issues


kmod-fglrx fails to install correctly from a kickstart file on EL6

Kickstart installs of kmod-fglrx fail on EL6. Uninstalling and reinstalling kmod-fglrx should fix the issue. See here:

http://elrepo.org/bugs/view.php?id=98 (external link)

A fix is to add the following line to the %post section of the kickstart script before installing the kmod package:

ln -s `awk '{ if ($2 == "/") print $1; }' /etc/fstab` /dev/root


Issues on Xorg version update

UPDATE:
New packages for fglrx version 14.9 and newer work just fine on EL 6.6 and 6.7. Note that fglrx-legacy requires the older ABI ( which was available in 6.4 and 6.5 ) and is not compatible with any release post 6.5.

The 6.4 release contains an updated Xorg that is not supported by older AMD fglrx releases (previous to 13.1). This issue is further compounded by the fact that the 13.1 driver drops support for older chipsets (Radeon HD 2000, HD 3000 and HD 4000 series) meaning that only Radeon HD 5000 series and above are now supported by the proprietary driver on EL6.4.

If you have a Radeon HD 5000, HD 6000 or HD 7000 series card you should update to kmod-fglrx-13.1 (or above) which is compatible with EL6.4.

If you have a Radeon HD 2000, HD 3000 or HD 4000 series card your options are:
1. When updating to 6.4, don't update xorg* packages or ATI/AMD driver, and add an exclude line to to your yum.conf to prevent further updating.
exclude=xorg* kmod-fglrx fglrx-x11-drv

2. Uninstall the AMD proprietary drivers and use the distro kernel drivers with 6.4.


Supported Chipsets

This driver is the current release and supports the most recent AMD/ATI based graphics cards. Prior to installing it please go to http://support.amd.com/en-us/download/desktop?os=Linux+x86#2 (external link) and verify if your chipset is on the supported list.

Users of cards based on older chipsets (see below) should use the older kmod-fglrx-legacy legacy driver which supports the following chipsets:


* RADEON 9500 PRO/9700 (R300 4E45)
* RADEON 9500 (R300 4144)
* RADEON 9500 (R350 4149)
* RADEON 9550 (RV350 4153)
* RADEON 9600 PRO (RV360 4152)
* RADEON 9600 (RV350 4150)
* RADEON 9600 (RV350 4E51)
* RADEON 9600 (RV351 4155)
* RADEON 9600 SE (RV350 4151)
* RADEON 9600 XT (R300 4146)
* RADEON 9600 XT (R300 4E46)
* RADEON 9700 PRO (R300 4E44)
* RADEON 9800 PRO (R350 4E48)
* RADEON 9800 (R350 4E49)
* RADEON 9800 SE (R350 4148)
* RADEON 9800 XT (R360 4E4A)
* RADEON X300 (RV370 5B60)
* RADEON X550 (RV370 5B63)
* RADEON X600 (RV380 3E50)
* RADEON X600 (RV380 5B62)
* RADEON X700 PRO (RV410 5E4B)
* RADEON X700 (RV410 5E4D)
* RADEON X700 (RV410 5E4F)
* RADEON X700 SE (RV410 5E4C)
* RADEON X700 XT (RV410 5E4A)
* RADEON X800 GTO (R430 554F)
* RADEON X800 GTO (R480 5D4F)
* RADEON X800 GT (R423 554B)
* RADEON X800 GT (R430 554E)
* RADEON X800 PRO (R420 4A49)
* RADEON X800 PRO (R423 5549)
* RADEON X800 (R420 4A48)
* RADEON X800 (R420 4A4C)
* RADEON X800 (R423 5548)
* RADEON X800 (R430 554F)
* RADEON X800 SE (R420 4A4A)
* RADEON X800 SE (R420 4A4F)
* RADEON X800 SE (R423 554B)
* RADEON X800 VE (R420 4A54)
* RADEON X800 XL (R430 554D)
* RADEON X800 XT Platinum Edition (R420 4A50)
* RADEON X800 XT Platinum Edition (R423 554A)
* RADEON X800 XT (R420 4A4B)
* RADEON X800 XT (R423 5D57)
* RADEON X850 PRO (R480 5D4F)
* RADEON X850 PRO (R481 4B4B)
* RADEON X850 (R481 4B48)
* RADEON X850 SE (R481 4B4A)
* RADEON X850 XT Platinum Edition (R480 5D4D)
* RADEON X850 XT Platinum Edition (R481 4B4C)
* RADEON X850 XT (R480 5D52)
* RADEON X850 XT (R481 4B49)
* RADEON X1200 (RS690 826D)
* RADEON X1300 (RV515)
* RADEON X1600 (R530)
* RADEON X1800 (R520)
* RADEON X1900 (R580)
* RADEON 2100 (RS740, 796e)




Page last modified on Wednesday 29 of July, 2015 09:39:31 MDT