ELRepo Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000435 [channel: kernel/el6] kernel-ml major always 2013-12-04 13:05 2013-12-07 13:20
Reporter psi-jack View Status public  
Assigned To burakkucat
Priority normal Resolution not a bug  
Status closed  
Summary 0000435: acpid fails to load due to acpi module failures - kernel-ml 3.12.2-1
Description acpid fails to start because acpi kernel modules fail:

# acpid
acpid: can't open /proc/acpi/event: No such file or directory

# modprobe acpi
FATAL: Error inserting acpi_cpufreq (/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko): No such device
Additional Information This happens in KVM virtual machine guests, so far that's all I've seen this issue show up on, haven't yet tested on physical hardware.
Tags No tags attached.
Reported upstream
Attached Files ? file icon config-312vs311.diff [^] (18,993 bytes) 2013-12-05 12:53

- Relationships

-  Notes
(0003414)
burakkucat (administrator)
2013-12-04 13:11
edited on: 2013-12-04 13:22

I am unable to reproduce the issue.

[quote]
[Duo2 ~]$ uname -r
3.12.2-1.el6.elrepo.x86_64
[Duo2 ~]$ find /lib/modules/$(uname -r) | sort | grep acpi
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_ipmi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_pad.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/sbshc.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/sbs.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/video.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/ata/pata_acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/hwmon/acpi_power_meter.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/mmc/host/sdhci-acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/thinkpad_acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/toshiba_acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/xen/xen-acpi-processor.ko
[Duo2 ~]$ lsmod | grep acpi
acpi_cpufreq 18334 1
freq_table 14264 2 cpufreq_ondemand,acpi_cpufreq
[Duo2 ~]$ modinfo acpi-cpufreq
filename: /lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
alias: acpi
license: GPL
description: ACPI Processor P-States Driver
author: Paul Diefenbaugh, Dominik Brodowski
srcversion: 41D9B90F763B0B98CABF623
alias: acpi*:ACPI0007:*
alias: acpi*:LNXCPU:*
alias: x86cpu:vendor:*:family:*:model:*:feature:*00E8*
alias: x86cpu:vendor:*:family:*:model:*:feature:*0016*
depends: freq_table
intree: Y
vermagic: 3.12.2-1.el6.elrepo.x86_64 SMP mod_unload modversions
parm: acpi_pstate_strict:value 0 or non-zero. non-zero -> strict ACPI checks are performed during frequency changes. (uint)
[Duo2 ~]$
[/quote]

I would suggest that you test once again, this time passing the -v and --dry-run flags to the modprobe command.

(0003424)
user396
2013-12-05 05:51

I don't get it myself, but I have repeated it many times on several of my KVM virtual machines. I have not tested with physical machines, but virtual kvm guests definitely for some reason are failing:

# uname -r
3.12.2-1.el6.elrepo.x86_64

# find /lib/modules/$(uname -r) | sort | grep acpi
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_ipmi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_pad.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/sbshc.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/sbs.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/acpi/video.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/ata/pata_acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/hwmon/acpi_power_meter.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/mmc/host/sdhci-acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/thinkpad_acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/toshiba_acpi.ko
/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/xen/xen-acpi-processor.ko

# lsmod | grep acpi
pata_acpi 13038 0

# modinfo acpi-cpufreq
filename: /lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
alias: acpi
license: GPL
description: ACPI Processor P-States Driver
author: Paul Diefenbaugh, Dominik Brodowski
srcversion: 41D9B90F763B0B98CABF623
alias: acpi*:ACPI0007:*
alias: acpi*:LNXCPU:*
alias: x86cpu:vendor:*:family:*:model:*:feature:*00E8*
alias: x86cpu:vendor:*:family:*:model:*:feature:*0016*
depends: freq_table
intree: Y
vermagic: 3.12.2-1.el6.elrepo.x86_64 SMP mod_unload modversions
parm: acpi_pstate_strict:value 0 or non-zero. non-zero -> strict ACPI checks are performed during frequency changes. (uint)

# modprobe -v acpi
insmod /lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
FATAL: Error inserting acpi_cpufreq (/lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko): No such device

# modprobe -v --dry-run acpi
insmod /lib/modules/3.12.2-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko

# lsmod | grep acpi
pata_acpi 13038 0
(0003425)
user396
2013-12-05 06:32

Adding to that, this is the results of rolling back kernels. acpid actually runs, the module stuff looks exactly identical except that acpi modules aren't loaded.

Here's the major difference, is acpi events doesn't exist in proc, what causes it, I'm not sure:

# uname -r
3.11.6-1.el6.elrepo.x86_64

# find /lib/modules/$(uname -r) | sort | grep acpi
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/acpi
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_ipmi.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_pad.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/acpi/sbshc.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/acpi/sbs.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/acpi/video.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/ata/pata_acpi.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/hwmon/acpi_power_meter.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/mmc/host/sdhci-acpi.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/thinkpad_acpi.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/toshiba_acpi.ko
/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/xen/xen-acpi-processor.ko

lsmod | grep acpi
pata_acpi 13038 0

# modinfo acpi-cpufreq
filename: /lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
alias: acpi
license: GPL
description: ACPI Processor P-States Driver
author: Paul Diefenbaugh, Dominik Brodowski
srcversion: ADC30A7FB003405AAA90FCF
alias: acpi*:ACPI0007:*
alias: acpi*:LNXCPU:*
alias: x86cpu:vendor:*:family:*:model:*:feature:*00E8*
alias: x86cpu:vendor:*:family:*:model:*:feature:*0016*
depends: freq_table,mperf
intree: Y
vermagic: 3.11.6-1.el6.elrepo.x86_64 SMP mod_unload modversions
parm: acpi_pstate_strict:value 0 or non-zero. non-zero -> strict ACPI checks are performed during frequency changes. (uint)


# ps ax | grep acpid
 1072 ? Ss 0:00 /usr/sbin/acpid

# modprobe acpi
FATAL: Error inserting acpi_cpufreq (/lib/modules/3.11.6-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko): No such device





On a 3.12.2-1 system:
# cd /proc/acpi/
# ls -la
total 0
dr-xr-xr-x. 4 root root 0 Dec 5 08:24 .
dr-xr-xr-x. 128 root root 0 Dec 4 09:09 ..
dr-xr-xr-x. 2 root root 0 Dec 5 08:25 ac_adapter
dr-xr-xr-x. 2 root root 0 Dec 5 08:25 battery
-rw-r--r--. 1 root root 0 Dec 5 08:25 wakeup


On a 3.11.6-1 system:
# ls -la
total 0
dr-xr-xr-x 4 root root 0 Dec 5 08:16 .
dr-xr-xr-x 117 root root 0 Dec 5 08:16 ..
dr-xr-xr-x 2 root root 0 Dec 5 08:31 ac_adapter
dr-xr-xr-x 2 root root 0 Dec 5 08:31 battery
-r-------- 1 root root 0 Dec 5 08:16 event
-rw-r--r-- 1 root root 0 Dec 5 08:31 wakeup
(0003427)
user396
2013-12-05 06:39

Related, same problem:
http://elrepo.org/bugs/view.php?id=347 [^]
(0003431)
burakkucat (administrator)
2013-12-05 10:17
edited on: 2013-12-05 10:20

Using the latest kernel-ml-3.12.3-1.el6.elrepo in a KVM guest, I see --

[Chroot64R6 ~]$ uname -a
Linux Chroot64R6 3.12.3-1.el6.elrepo.x86_64 #1 SMP Thu Dec 5 01:18:49 EST 2013 x86_64 x86_64 x86_64 GNU/Linux
[Chroot64R6 ~]$ ll -R /proc/acpi
/proc/acpi:
total 0
dr-xr-xr-x 2 root root 0 Dec 5 12:02 ac_adapter
dr-xr-xr-x 2 root root 0 Dec 5 12:02 battery
-rw-r--r-- 1 root root 0 Dec 5 12:02 wakeup

/proc/acpi/ac_adapter:
total 0

/proc/acpi/battery:
total 0
[Chroot64R6 ~]$ lsmod | head
Module Size Used by
autofs4 32659 4
ipt_REJECT 12576 1
nf_conntrack_ipv4 19787 9
nf_defrag_ipv4 12758 1 nf_conntrack_ipv4
iptable_filter 12810 1
ip_tables 27213 1 iptable_filter
ip6t_REJECT 12609 2
nf_conntrack_ipv6 18380 2
nf_defrag_ipv6 33794 1 nf_conntrack_ipv6
[Chroot64R6 ~]$ lsmod | grep acpi
pata_acpi 13038 0
[Chroot64R6 ~]$ find /lib/modules/$(uname -r)/ -name \*acpi\* | sort
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/acpi
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_ipmi.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/acpi/acpi_pad.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/ata/pata_acpi.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/hwmon/acpi_power_meter.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/mmc/host/sdhci-acpi.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/thinkpad_acpi.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/platform/x86/toshiba_acpi.ko
/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/xen/xen-acpi-processor.ko
[Chroot64R6 ~]$ ps ax | grep acpi
 1041 ? S 0:00 /usr/libexec/hald-addon-acpi
 1353 pts/0 S+ 0:00 grep acpi
[Chroot64R6 ~]$ sudo modprobe acpi
FATAL: Error inserting acpi_cpufreq (/lib/modules/3.12.3-1.el6.elrepo.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko): No such device
[Chroot64R6 ~]$ grep _ACPI_PROC /boot/config-2.6.32-431.el6.x86_64
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROCFS_POWER=y
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_PROCESSOR_AGGREGATOR=m
[Chroot64R6 ~]$ grep _ACPI_PROC /boot/config-3.12.3-1.el6.elrepo.x86_64
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROCFS_POWER=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_PROCESSOR_AGGREGATOR=m
CONFIG_XEN_ACPI_PROCESSOR=m
[Chroot64R6 ~]$

The questions to be answered are:

(1) Is this due to a kernel deficiency?
(2) Is this a KVM container issue? i.e. userland issue?

(0003434)
user396
2013-12-05 12:52

1> Not mainline issue.
2> Not virtualization-related at all.

It's configuration related:

# diff -u config-3.11.6-1.el6.elrepo.x86_64 config-3.12.2-1.el6.elrepo.x86_64 | grep ACPI
 CONFIG_ACPI_PROCFS=y
 CONFIG_ACPI_PROCFS_POWER=y
 # CONFIG_ACPI_EC_DEBUGFS is not set
-CONFIG_ACPI_PROC_EVENT=y
 CONFIG_ACPI_AC=y
 CONFIG_ACPI_BATTERY=y
 CONFIG_ACPI_BUTTON=y
 CONFIG_ACPI_VIDEO=m
 CONFIG_ACPI_FAN=y
 CONFIG_ACPI_DOCK=y
-CONFIG_ACPI_I2C=y
 CONFIG_ACPI_PROCESSOR=y
 CONFIG_ACPI_IPMI=m
 CONFIG_ACPI_HOTPLUG_CPU=y




And to show CentOS standard with elrepo kernel-ml:

# diff -u config-2.6.32-431.el6.x86_64 config-3.12.2-1.el6.elrepo.x86_64 | grep ACPI_PROC_EVENT
-CONFIG_ACPI_PROC_EVENT=y


CONFIG_ACPI_PROC_EVENT is not being enabled per EL6 standards.

There's actually quite a few CONFIG differences between 3.11.x and 3.12.x. Attaching diff between 3.11 and 3.12 configs.
(0003437)
burakkucat (administrator)
2013-12-05 18:14

I have examined the configurations of the 3.11.6 and 3.12.3 kernel-ml packages.

Yes, I agree. Considering the ACPI configuration options only, CONFIG_ACPI_PROC_EVENT and CONFIG_ACPI_I2C are set (Y) for the 3.11.X kernel series but do not exist in the 3.12.Y kernel sources.

This is a bit of a quandary. It is not a misconfiguration on our part, for we cannot configure what does not exist.

Diff'ing the two Kconfig files (diff 3.11.6 3.12.3) I see --

< config ACPI_PROC_EVENT
< bool "Deprecated /proc/acpi/event support"
< depends on PROC_FS
< default y
< help
< A user-space daemon, acpid, typically reads /proc/acpi/event
< and handles all ACPI-generated events.
<
< These events are now delivered to user-space either
< via the input layer or as netlink events.
<
< This build option enables the old code for legacy
< user-space implementation. After some time, this will
< be moved under CONFIG_ACPI_PROCFS, and then deleted.
<
< Say Y here to retain the old behaviour. Say N if your
< user-space is newer than kernel 2.6.23 (September 2007).
<
< config ACPI_I2C
< def_tristate I2C
< depends on I2C
< help
< ACPI I2C enumeration support.
<

Please open an issue report upstream [1] and then add the relevant bz number to this report.

[1] https://bugzilla.kernel.org/ [^]
(0003438)
psi-jack (reporter)
2013-12-05 20:09

Bug filed with upstream kernel:
https://bugzilla.kernel.org/show_bug.cgi?id=66681 [^]
(0003440)
burakkucat (administrator)
2013-12-05 20:40

Thank you for providing the upstream bug number.
(0003449)
burakkucat (administrator)
2013-12-07 11:04
edited on: 2013-12-08 17:28

I am closing this as "not a bug".

The resolution to this issue needs to be provided in userland -- by an upgrade to the ACPI sub-system.


- Issue History
Date Modified Username Field Change
2013-12-04 13:05 user396 New Issue
2013-12-04 13:05 user396 Status new => assigned
2013-12-04 13:05 user396 Assigned To => burakkucat
2013-12-04 13:11 burakkucat Note Added: 0003414
2013-12-04 13:18 burakkucat Note Edited: 0003414
2013-12-04 13:22 burakkucat Note Edited: 0003414
2013-12-05 05:51 user396 Note Added: 0003424
2013-12-05 06:32 user396 Note Added: 0003425
2013-12-05 06:39 user396 Note Added: 0003427
2013-12-05 10:17 burakkucat Note Added: 0003431
2013-12-05 10:20 burakkucat Note Edited: 0003431
2013-12-05 12:52 user396 Note Added: 0003434
2013-12-05 12:53 user396 File Added: config-312vs311.diff
2013-12-05 18:14 burakkucat Note Added: 0003437
2013-12-05 20:09 psi-jack Note Added: 0003438
2013-12-05 20:40 burakkucat Note Added: 0003440
2013-12-06 10:45 burakkucat Note Added: 0003443
2013-12-07 11:04 burakkucat Note Added: 0003449
2013-12-07 11:04 burakkucat Status assigned => closed
2013-12-07 11:04 burakkucat Resolution open => not a bug
2013-12-07 13:20 burakkucat Reporter user396 => psi-jack
2013-12-08 09:15 burakkucat Note Edited: 0003449
2013-12-08 17:28 burakkucat Note Edited: 0003449
2013-12-08 17:28 burakkucat Note Deleted: 0003443


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker