ELRepo Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000401 [channel: kernel/el5] kernel-ml crash always 2013-08-13 09:16 2014-05-21 14:34
Reporter Spacedust View Status public  
Assigned To burakkucat
Priority normal Resolution not a bug  
Status closed  
Summary 0000401: module scsi_wait_scan not found
Description After upgrading kernel 3.10.4-1 to 3.10.5-1 or 3.10.6-1 the system is refusing to boot with module scsi_wait_scan not found error message. Then comes kernel panic.
Additional Information See attached screenshot for details.

Updating dracut didn't helped !

I'm on CentOS 6.4 64-bit and dedicated machine.
Tags No tags attached.
Reported upstream https://bugzilla.kernel.org/show_bug.cgi?id=60758 [^]
Attached Files jpg file icon crash.jpg [^] (273,667 bytes) 2013-08-13 09:16

- Relationships

-  Notes
(0003235)
burakkucat (administrator)
2013-08-13 11:55

Beginning with linux-3.6, there has not been a scsi_wait_scan module available. (It was last present in the linux-3.5.7 source code.)

The message "module scsi_wait_scan not found" originates from a line in the init file, contained within the initramfs image. The init file has a line --

modprobe scsi_wait_scan && modprobe -r scsi_wait_scan

and it is the failure of the initial modprobe command which causes that message to be displayed.

The fact that there is no scsi_wait_scan module is not the cause of the panic but is due to some other deficiency in the initramfs image that has been built for your system.

I am currently using kernel-ml-3.10.6-1.el6.elrepo.x86_64 and am unable to reproduce the problem that you are experiencing.

[Duo2 ~]$ rpm -q kernel-ml
kernel-ml-3.10.6-1.el6.elrepo.x86_64
[Duo2 ~]$ uname -a
Linux Duo2 3.10.6-1.el6.elrepo.x86_64 #1 SMP Mon Aug 12 23:45:59 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux
[Duo2 ~]$
(0003236)
Spacedust (reporter)
2013-08-13 12:05

It happens only on this one machine. How to resolve this ?

Can I comment this line and try booting again ?
(0003237)
burakkucat (administrator)
2013-08-13 12:14

My reply to your first question is "I do not know. I am unable to reproduce it."

As to you second question, yes, unpacking the current initramfs, editing the init file, repacking the initramfs (with a different name) and modifying the boot stanza in the /etc/grub.conf file to reference the new initramfs would be a sensible experiment.

The other thing to do would be to boot the last version of kernel-ml that runs correctly on that hardware and take a note (lsmod) of any scsi drivers that are loaded. Then ensure that those scsi drivers are pre-loaded into the initramfs.
(0003238)
Spacedust (reporter)
2013-08-13 12:20

3.10.4-1 boots just fine.
(0003239)
Spacedust (reporter)
2013-08-30 01:25

At kernel.org they ask for:

"Looks like a dependency failure, would you like to show the two .config files?"

Can I get these files ?
(0003240)
burakkucat (administrator)
2013-08-30 07:26

You will find the configuration file for every kernel installed on your system in the /boot/ directory.

Each file name begins with the string "config-" and the latter part of the name is specific to each particular kernel.

If you are interested in the configuration file for a kernel that you do not have installed, just download the package and use the 'rpm2cpio' command, along with 'cpio', to extract the file.

Older kernel packages may be obtained from the archive. Not all mirror sites carry the archive, so you may have to look 'further afield'.
(0003242)
Spacedust (reporter)
2013-08-31 06:36

I got reply:

--- Comment #5 from Jeff Zhou <jz.researcher@yahoo.com> --- If your system fails by "module scsi_wait_scan not found", then it could be the init script issue in your CentOS box.

The last kernel with scsi_wait_scan.ko is v3.5.7, it has been removed ever since v3.6. Any init script for 3.10 should not use that module.


Another point is in your config, the CONFIG_SCSI_SCAN_ASYNC is not set, try to turn it into Y and see what's happening.
(0003281)
Spacedust (reporter)
2013-09-22 14:58

Still crashing on 3.11.1-2.el6.elrepo.x86_64 on H87 chipset. Upgraded my other board Intel D425KT and that one runs without any problems.

- Issue History
Date Modified Username Field Change
2013-08-13 09:16 Spacedust New Issue
2013-08-13 09:16 Spacedust Status new => assigned
2013-08-13 09:16 Spacedust Assigned To => burakkucat
2013-08-13 09:16 Spacedust File Added: crash.jpg
2013-08-13 09:16 Spacedust Reported upstream => 3.10.6-1
2013-08-13 11:55 burakkucat Reported upstream 3.10.6-1 =>
2013-08-13 11:55 burakkucat Note Added: 0003235
2013-08-13 12:05 Spacedust Note Added: 0003236
2013-08-13 12:14 burakkucat Note Added: 0003237
2013-08-13 12:20 Spacedust Note Added: 0003238
2013-08-30 01:25 Spacedust Note Added: 0003239
2013-08-30 07:26 burakkucat Note Added: 0003240
2013-08-31 06:36 Spacedust Note Added: 0003242
2013-08-31 09:39 burakkucat Reported upstream => https://bugzilla.kernel.org/show_bug.cgi?id=60758 [^]
2013-09-22 14:58 Spacedust Note Added: 0003281
2014-05-21 14:34 burakkucat Status assigned => closed
2014-05-21 14:34 burakkucat Resolution open => not a bug


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker