ELRepo Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000249 [channel: elrepo/el6] kmod-nvidia crash always 2012-03-25 09:51 2012-03-25 11:20
Reporter danlugli View Status public  
Assigned To pperry
Priority normal Resolution open  
Status assigned  
Summary 0000249: scrambled graphics and freeze/reboot with kmod-nvidia-295.20-1.el6.elrepo and kmod-nvidia-295.33-1.el6.elrepo, GEFORCE GTX 560M
Description notebook Asus G74S
graphic card nvidia geforce gtx 560M
OS CentOS 6.2
kernel 2.6.32

I tried four different ways:

1) NVIDIA-Linux-x86_64-295.20.run downloaded from www.nvidia.com and installed manually. Some hours after installation I had a freeze followed by a spontaneous reboot while running a c++ build with Eclipse IDE (with output messages scrolling in the output pane). Then it happened again. Maybe these messages:
Mar 14 18:32:01 localhost kernel: NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
Mar 14 18:32:03 localhost kernel: NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
Mar 14 18:32:05 localhost kernel: NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
Mar 14 18:32:07 localhost kernel: NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
from /var/log/messages are somehow related. After the third freeze/reboot I gave up.

2) Same driver, but from Elrepo repository, packaged as kmod-nvidia-295.20-1.el6.elrepo and nvidia-x11-drv-295.20-1.el6.elrepo. No freeze/reboot here, but occasionally (many times per day), under stress, the display gets 'scrambled' (lines of text disappearing or unreadable, images with missing portions, mixture of graphics from different workspaces, ...). Sometimes it recovers by itself and sometimes I need to force a refresh by doing something, eg minimizing/maximizing a window or changing workspace.

3) Older driver from ElRepo, kmod-nvidia-290.10-1.el6.elrepo and nvidia-x11-drv-290.10-1.el6.elrepo: spontaneous reboot after half an hour.

4) More recent driver from elrepo: kmod-nvidia-295.33-1.el6.elrepo and nvidia-x11-drv-295.3-1.el6.elrepo. Here the problems are similar to point (2) but less frequent.

Same bug report submitted to nvidia tracking system with follow-up #120325-000017

Please feel free to contact me for any question.

Thank you
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0001907)
pschaff (reporter)
2012-03-25 10:17

This bug report was a result of a CentOS forum thread:

 https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=36286&forum=57 [^]

A link to the Nvidia report would be helpful. I can't seem to find it.
(0001908)
pperry (administrator)
2012-03-25 11:20

Acknowledged, and thanks.

As stated in the above forum thread and deduced from your testing, this does appear to be an issue with the nvidia driver rather than the elrepo packaging of the driver.

- Issue History
Date Modified Username Field Change
2012-03-25 09:51 danlugli New Issue
2012-03-25 09:51 danlugli Status new => assigned
2012-03-25 09:51 danlugli Assigned To => stindall
2012-03-25 10:02 toracat Project elrepo bug tracker => channel: elrepo/el6
2012-03-25 10:03 toracat Assigned To stindall => pperry
2012-03-25 10:03 toracat Category --bug-tracker--OTHER-- => kmod-nvidia
2012-03-25 10:17 pschaff Note Added: 0001907
2012-03-25 10:17 pschaff Issue Monitored: pschaff
2012-03-25 11:20 pperry Note Added: 0001908


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker